November 24, 2020, 07:37:00 PM
HDBitchin, a Harley Davidson Forum
Cookie Settings

Author Topic: Triglide won't start  (Read 218 times)

0 Members and 1 Guest are viewing this topic.

July 31, 2020, 10:32:02 AM
Read 218 times
Offline

Elkridge


Parked my 2016 triglide last fall, was ok when I shut it off, plugged in battery tender and covered it up. Pulled it out today, turned on ignition, security light blinks, pushed starter switch (Nothing) I have 12.77 volts at battery tender connector. No lights, no console, radio, or signal. New battery in FO B, any suggestions

July 31, 2020, 11:17:57 AM
Reply #1
Offline

maniacmac

Global Moderator
Parked my 2016 triglide last fall, was ok when I shut it off, plugged in battery tender and covered it up. Pulled it out today, turned on ignition, security light blinks, pushed starter switch (Nothing) I have 12.77 volts at battery tender connector. No lights, no console, radio, or signal. New battery in FO B, any suggestions
Check cable connection and don't forget the ground cable. Take the connections apart and inspect, over time they can corrode causing a bad connection.

July 31, 2020, 04:41:10 PM
Reply #2
Online

HDBitchin

Administrator
@Elkridge

@maniacmac gave the best advice. With all those things that you mentioned not lighting (lights, no console, radio, or signals) it really sounds like your battery has a loose connection on the positive or negative cables.
HDBitchin aka Tank
AMA Member- Click Here to Join
When shopping for anything look for Made in the USA and save American jobs and families


July 31, 2020, 09:46:21 PM
Reply #3
Offline

bc45

Global Moderator
@Elkridge If the security light is flashing and no power up on the dash the security system is tripped, have you  tested the battery or put new battery in the fob. I know if I try to turn on my 16 FLHTK and also on my 09 FLHTCU with out the fob I would get that condition, the Security light flashing and no power up of any thing else.

August 01, 2020, 05:30:44 AM
Reply #4
Offline

bc45

Global Moderator
@Elkridge  I forgot tho mention if it is the security it should say enter pin , if it does not then check the battery as maniacmac suggested

August 13, 2020, 09:20:30 AM
Reply #5
Offline

NoSuperSlabs

Supporting Member
Hey @Elkridge a follow up would be appreciated. Anything that you have learned will benefit others that might be having a similar problem/issue.

If you still have a problem then please ask the next set of questions and we will try to assist your further.

A forum is for sharing. 
Two Lane Highway
Agree Agree x 2 View List


 



The Harley-Davidson names and logos are Trademarks owned by Harley-Davidson, Inc. This site is not affiliated with Harley-Davidson.
All trademarks are the property of their respective owners and may be registered marks in some countries. There is no affiliation or endorsement claim, express or implied, made by their use.
All artwork in the HDBitchin logos including "Popeye" our Harley riding and forum surfing mascot is artwork that is © of HDBitchin
© HDBitchin, a HD Forum 2013 - 2020 All rights reserved.


HDBitchin is a web property of Tank Oils, an Independent AMSOIL Dealer