February 17, 2020, 05:48:09 AM
HDBitchin, a Harley Davidson Forum
Cookie Settings

Author Topic: 2000 Electra glide, throwing code 55 ECM  (Read 168 times)

0 Members and 1 Guest are viewing this topic.

February 05, 2020, 11:03:30 AM
Read 168 times
Offline

HogHazard


Ok, so here goes my attempt at explaining the entire situation.  Little patience may be required.

I left town for approximately 3 weeks, day prior to leaving my bike ran excellent. When I returned went for a nice long day ride again ran perfect. Next day went to ride and it did something weird which it kinda started and then shut off but then started right back up.  So I rode to the gas station about 1 mile from my house, after fueling I went to turn on ignition and zero power to anything, (NOTHING).

After towing her home I started searching online and reading my service manual. And signs started pointing to the ignition switch itself. Mind you I should've done a few more tests before assuming or in other words making an ass outta myself. Turned out to be the battery had lost 2 cells after 1 week waiting on the ignition switch and another following the power.

So new battery she fired right up everything was beautiful.  Rode for about 2 hrs just putting around town, and suddenly it's like I lost power and the rear cylinder was getting extremely hot. None the less lumped her home checked for compression, changed the spark plugs and checked the power of spark to each cylinder.  Then made sure I had gas going to the injectors which I did and everything checked out.

So here we are, the stator checks out. I am pulling all the right power to the right locations. And finally resort to checking the onboard codes. At this time I thinking finally found it. Bike is throwing the 55 code which is microprocessor failure, service manual says to replace the ECM for this code. However from what I've been hearing this is very odd for it to go bad.

Any help on this would be greatly appreciated. Also if any of yuins have one of these on the shelf let me know. Thanks in advance.

February 05, 2020, 12:49:50 PM
Reply #1
Offline

maniacmac

Global Moderator
Try unhooking the ground to the battery and wait 30 minutes, turn ing. switch on then back off. Reconnect the ground cable and turn ing. switch on. This should cold boot your ecm
wish you luck. FYI you don't just buy a ecm off the shelf it has to be programed

February 05, 2020, 01:02:02 PM
Reply #2
Online

HDBitchin

Administrator
Here is the link to the forum thread for DTC LIst for 2003 and Older Harleys. The source of the DTC list in that thread is from a 2003 manual so that might make some difference as to why I don’t see a 55 in that DTC List. Your picture shows a page from a manual so in the model year 2000 that code (55) must be valid and later years was removed. 

One thing you might try prior to replacing the ECM is to inspect the connector for a firm solid connection and then remove the ECM’s connector and inspect it for corrosion. Even if you don’t see any visible corrosion I would get some electrical contact cleaner and give the plug a proper cleaning. Clean both the wiring harness side connector and the ECM side. Be careful not to soak the ECM with the contact cleaner. Take it easy so you don’t penetrate the internal circuitry. When dry reconnect and see if things have improved. 

When you plug it back be certain that the plug seated properly.

February 07, 2020, 07:39:50 PM
Reply #3
Offline

maniacmac

Global Moderator
Any updates

February 14, 2020, 01:52:34 PM
Reply #4
Offline

WantMore

Supporting Member
As already asked, any updates @HogHazard ?
Smoke em if you got em


 



The Harley-Davidson names and logos are Trademarks owned by Harley-Davidson, Inc. This site is not affiliated with Harley-Davidson.
All trademarks are the property of their respective owners and may be registered marks in some countries. There is no affiliation or endorsement claim, express or implied, made by their use.
All artwork in the HDBitchin logos including "Popeye" our Harley riding and forum surfing mascot is artwork that is © of HDBitchin
© HDBitchin, a HD Forum 2013 - 2020 All rights reserved.


HDBitchin is a web property of Tank Oils, an Independent AMSOIL Dealer